Author Topic: XMPlay issue  (Read 7211 times)

Offline Axxy

  • Sr. Member
  • ****
  • Posts: 463
    • View Profile
XMPlay issue
« on: March 22, 2015, 15:11:06 »
I've attached a module that xmplay just falls over itself trying to play. Every other player/tracker seems to have no problem recognising it.  It's why I hate xmplay when trying to load all mods into it.

Is the module corrupt?
Anyone recognise the module (probably off of Mods Anthology or something)?
Who wrote it? or from what production?


Offline Asle

  • Administrator
  • Hero Member
  • *****
  • Posts: 1 032
    • View Profile
    • Amiga Music Preservation
Re: XMPlay issue
« Reply #1 on: March 22, 2015, 16:27:31 »
Nothing seems wrong with this file.
Can't say much about xmplay (never used), but in this case, you can use the original music (MOD.cameroon dark!!!) by Grim :)
This one comes from Fish & Chips #1 musicdisk by Sonic

Cheers

Offline Axxy

  • Sr. Member
  • ****
  • Posts: 463
    • View Profile
Re: XMPlay issue
« Reply #2 on: March 22, 2015, 21:18:00 »
nice, cheers 8

Offline deus-ex

  • Sr. Member
  • ****
  • Posts: 478
    • View Profile
Re: XMPlay issue
« Reply #3 on: March 23, 2015, 19:29:42 »
Hi Axxy,

here XMPlay plays your attached module without any issues. Are you using any third-party plugins, perhaps one of these is interfering? You may want to try the latest binary of XMPlay (attached).
Best regards
deus-ex

Offline Axxy

  • Sr. Member
  • ****
  • Posts: 463
    • View Profile
Re: XMPlay issue
« Reply #4 on: March 23, 2015, 20:04:19 »
Hi Axxy,

here XMPlay plays your attached module without any issues. Are you using any third-party plugins, perhaps one of these is interfering? You may want to try the latest binary of XMPlay (attached).

I'm currently using XMPlay 3.8.1.2. I can't play this particular mod at all in XMPlay. Just crashes it. Everything else has no problem with it, even resaving it in other trackers/players. Unfortunately, this is one of many modules that XMPlay can't load for whatever reason.

All plugins are currently off the website, so shouldn't conflict with the player  as they are only plugins to play different formats.  I can't see why a 4 channel protracker mod causes xmplay so much trouble, but I will try it without any plugins to see which one is causing the issue.

Offline deus-ex

  • Sr. Member
  • ****
  • Posts: 478
    • View Profile
Re: XMPlay issue
« Reply #5 on: March 23, 2015, 20:27:53 »
If the problem persists after ruling out any plugins the problem might be related to a certain configuration setting of XMPlay. You can try with default values by renaming your current Xmplay.ini (e.g. !Xmplay.ini). Or simply extract the archive attached to my previous post to a new folder and test with that release of XMPlay.
Best regards
deus-ex

Offline Axxy

  • Sr. Member
  • ****
  • Posts: 463
    • View Profile
Re: XMPlay issue
« Reply #6 on: March 23, 2015, 20:37:43 »
Lol, my AV booted the .exe from the archive. Didn't even get chance to say no. Probably a false/positive.

Offline deus-ex

  • Sr. Member
  • ****
  • Posts: 478
    • View Profile
Re: XMPlay issue
« Reply #7 on: March 23, 2015, 20:53:49 »
Probably you should give your current AV the boot. You can fetch the latest XMPlay binary yourself here, the .DLLs of the official 3.8.1.2 distribution remained unchanged: http://www.un4seen.com/stuff/xmplay.exe
Best regards
deus-ex

Offline Axxy

  • Sr. Member
  • ****
  • Posts: 463
    • View Profile
Re: XMPlay issue
« Reply #8 on: March 23, 2015, 20:54:52 »
Seems the Crunchmania dll (crm.dll) is the problem. Remove that and the mod plays just fine.

Offline deus-ex

  • Sr. Member
  • ****
  • Posts: 478
    • View Profile
Re: XMPlay issue
« Reply #9 on: March 23, 2015, 22:01:45 »
So it turned out XMPlay isn't to blame. Crunch-Media.dll is a third-party plugin by Sebastian Szczepaniak, aka Fraggie on the XMPlay forum.
Best regards
deus-ex

Offline Axxy

  • Sr. Member
  • ****
  • Posts: 463
    • View Profile
Re: XMPlay issue
« Reply #10 on: March 23, 2015, 23:01:06 »
Yep, been so long since I looked in the xmplay folder :)

Didn't realise I had so many plugins in there. Just don't understand why the crm.dll would interfere with a normal mod though.

Offline Asle

  • Administrator
  • Hero Member
  • *****
  • Posts: 1 032
    • View Profile
    • Amiga Music Preservation
Re: XMPlay issue
« Reply #11 on: March 23, 2015, 23:42:53 »
probably because the file starts with "crm", one of the ID tags of CrunchMania packer, handled by this dll to decrunch on the fly, I bet.

Offline Axxy

  • Sr. Member
  • ****
  • Posts: 463
    • View Profile
Re: XMPlay issue
« Reply #12 on: March 24, 2015, 11:08:52 »
probably because the file starts with "crm", one of the ID tags of CrunchMania packer, handled by this dll to decrunch on the fly, I bet.


I think there's 5 or 6 modules off Mods Anthology where they came from called crm1-7, all unknown apart from the one you mentioned earlier